Referencias relativas, absolutas y mixtas (2019)

En Excel existen tres tipos de referencias, RELATIVAS, ABSOLUTAS y MIXTAS. Veamos cada una de ellas siguiendo estos sencillos ejemplos.

En la tabla tenemos los datos de las ventas de 10 productos realizadas por 5 comerciales en el  del primer semestre de 2019, debemos calcular los totales de ventas por cada comercial y los totales de cada producto vendido. Para realizar estos cálculos vamos a utilizar la función =SUMA(). Así para calcular el total vendido por el comercial 1, la función que debemos aplicar es =SUMA(C6:C15) y a continuación la propagamos hacia la derecha. Igualmente en la columna de totales de productos vendido, emplearemos la misma función  =SUMA(C6:G6) y a continuación la propagamos hacia abajo.

 

Para completar la  tabla hemos empleado referencias relativas.

Una referencia relativa es el tipo de referencia más usado en las fórmulas y son aquellas que se ajustan y cambian cuando se copian o se usa el Auto llenado.

En la siguiente tabla y teniendo en cuenta los totales de venta de cada producto debemos calcular el total neto de cada producto. Para realizar este cálculo debemos tener en cuenta las comisiones de cada comercial, los impuestos aplicados, y los gastos fijos de 500€.

Para completar la tabla, usaremos los totales de venta de cada producto y le aplicaremos el porcentaje de la comisión correspondiente para obtener el Total comisiones, de manera similar lo haremos para obtener el Total de impuestos … para obtener el Total Neto restaremos el Total de comisiones, el total de impuestos y los gastos fijos al total de ventas.

Podemos ver en las fórmula que  hemos usado referencias absolutas.

En una referencia absoluta la referencia de celda permanece igual si se copia o se mueve la celda a cualquier otra celda. Esto se hace bloqueando la fila y la columna por lo que no cambia cuando se mueve o se copia. Se identifica por el símbolo de $ para bloquear fila y columna. También se puede hacer mediante la tecla F4.

Si no hubiésemos usado referencias absolutas el resultado hubiese sido un error:

Si lo vemos desde la opción de auditoria de fórmulas y rastrear los precedentes vemos el porqué del error:

Al usar referencias relativas, y propagar (Auto relleno) la función por la columna, la posición del dato de comisiones (5%) o de Impuestos (15%) ha ido moviéndose también a celdas vacías, por eso debemos bloquear esa celda y evitaremos el error… usaremos siempre Referencias absolutas.

Para ver las referencias mixtas lo haremos con un ejemplo diferente, sencillo… fácil de comprender. La Tabla de multiplicar.

Una referencia mixta es aquella que puede bloquear la fila o la columna de manera que cuando la copiemos o movemos la celda se mueva una y otra no.

Si utilizamos referencias relativas…

 

Por lo tanto la solución será utilizar referencias mixtas, para que sea más fácil de entender, a la columna la llamaremos Multiplicando y a la fila Multiplicador:

  • Bloquearemos la columna cuando queremos arrastrar a la derecha la fórmula y que siempre vaya a buscar el dato en el multiplicando, en nuestro caso sería $D6
  • Bloquearemos la fila cuando queremos arrastrar hacia abajo la fórmula y que siempre vaya a buscar el dato en el multiplicador, en nuestro caso sería E$5
  • La fórmula quedará del siguiente modo, =$D6*E$5 y el resultado será correcto. Propagamos (Auto relleno)
  • Recuerda que podemos usar la tecla F4 para añadir el símbolo del $… debemos ir pulsando hasta llegar a la posición correcta.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información

ACEPTAR
Aviso de cookies
error: